最新消息:本站介绍:国外VPS、云服务器,海外服务器,一手资源推荐平台

Linux Kernel 5.19.1 错误可能会损坏英特尔笔记本电脑的显示器

行业文章 快米云 来源:快米云 57浏览

Linux 错误

Linux 用户报告说,在升级到 Linux 内核版本 5.19.12 后,他们的英特尔笔记本电脑显示屏上出现奇怪的白色闪烁和快速闪烁,从而导致警告说该错误可能会损坏显示屏。

Linux 内核版本 5.19.12 不是实验性或测试版,而是 2022 年 9 月 28 日发布的稳定分支的一个点版本。

除了视觉上的烦恼之外, 意外的屏幕闪烁 还会阻止用户在他们的系统上执行任何操作,英特尔 Linux 内核工程师 Ville Syrjäl 警告说,它还可能损坏显示器。

在分析了受此问题影响的用户的 Linux 日志后,  Syrjäl 回复 内核邮件列表,称问题在于虚假的面板电源排序延迟,这可能会损坏面板。

Syrjä 建议立即将 Linux 内核恢复为旧版本,以避免对人们的机器造成硬件损坏,并发布“没有人使用配备英特尔 GPU 的笔记本电脑运行 5.19.2”的建议。

不幸的是,在许多用户已经升级到有缺陷的 Linux 版本之后才意识到这一点,这可能会损坏他们的系统并被迫应用内核版本降级。

受此问题影响的最大用户社区是 Framework 笔记本电脑, 在升级到 Linux 内核 5.19.2 后报告 Arch 和 Fedora出现问题。

稳定分支的主要维护者 Greg Kroah-Hartman  于周二发布了内核版本 5.19.13 ,解决了这个问题并为 Linux 发行版提供了一个安全的跳板。

“此版本旨在解决某些英特尔图形系统在 5.19.12 中出现问题的问题。如果您在 5.19.12 中没有此问题,则无需升级,”发布公告中写道。

流行的基于 Arch 的发行版 Majaro 已经 宣布他们 将从 5.19.7 直接跳到 5.19.13,避免给英特尔 GPU 笔记本电脑用户带来风险。

然而,鉴于在许多其他发行版上推动 Linux 内核升级的延迟,有缺陷的版本可能会在稍后出现在其中一些发行版上。

建议用户在升级前检查内核版本号,如果他们使用的是英特尔笔记本电脑,请避免使用 Linux 5.19.12。

建议那些已经受到该错误影响的人不要让他们的显示器长时间以闪烁模式运行,因为这会增加对屏幕造成不可逆转损坏的机会。

通常,引导加载程序允许用户从最后三个内核版本中进行选择,因此恢复到没有问题的版本应该不会太难。

如果您在 Grub 上没有看到该选项,请在启动时按住键盘上的“Shift”按钮。

与此同时, Linus Torvalds 周日宣布发布主线版本 6.0  ,支持 Arc GPU、AMD RDNA 3 和英特尔“Raptor Lake”、英特尔至强和 AMD EPYC 芯片的性能提升调度程序更改、能源调整和更多的。

下一个里程碑将是 6.1 版本,它可能是第一个用 Rust 编写的,Rust 是一种提供原始速度和灵活性的高性能内存安全编程语言。

转载请注明:VPS资讯_海外云服务器资讯_海外服务器资讯_IDC新闻 » Linux Kernel 5.19.1 错误可能会损坏英特尔笔记本电脑的显示器