最新消息:本站介绍:国外VPS、云服务器,海外服务器,一手资源推荐平台

WordPress正在放弃对版本3.7-4.0的支持

行业文章 快米云 来源:快米云 33浏览

WordPress 正在放弃对版本 3.7-4.0 的支持

  • WordPress安全团队发布了 3.7 和 4.0 之间的最终版本,分别是 3.7.41、3.8.41、3.9.40 和 4.0.38。
  • 放弃对不到总安装量 1% 的旧版本的支持,使团队可以专注于新版本。
  • 通知随最终更新一起发送,通知用户他们的 WordPress 版本将不会收到新的安全更新。

几个月前,WordPress安全团队宣布从2022 年 12 月 1 日起不再提供WordPress 3.7 至 4.0 版的安全更新。WordPress 3.7 于 2013 年 10 月发布,并引入了自动后台更新。使用 3.7 和 4.0 之间版本的网站不到总安装量的 1%。

专注于新版本

WordPress 安全团队表示,向后移植旧版本的安全更新是一个耗时的过程,该团队大部分时间都在为少数 WordPress 安装准备反向移植。因此,该团队决定放弃对 4.0 之前版本的支持。

11 月 29 日,安全团队发布了这些版本的最终版本。最终版本将保持为 3.7.41、3.8.41、3.9.40 和 4.0.38。从现在开始,该团队将专注于最新版本,而不是为旧版本反向移植安全更新。在最终版本中,用户会收到升级通知,声明他们的版本不会收到新的安全更新。在 9 月份发布的公告中,WordPress 安全团队表示,

« WordPress 的过时版本(在本例中为 4.0.* 及更早版本)将在仪表板中显示不可关闭的通知,通知用户有更新可用。在这些 WordPress 版本的最终更新中,这些通知将变得更加突出,并通知管理员他们的 WordPress 版本不再接收安全更新。

一个额外的字符串将添加到代码库中,以允许将来放弃安全支持。这些字符串将被提交到主干并在发布日期之前向后移植到每个早期版本。这将允许 Polyglot 团队翻译它们,并让字符串开始出现在翻译包中。»

转载请注明:VPS资讯_海外云服务器资讯_海外服务器资讯_IDC新闻 » WordPress正在放弃对版本3.7-4.0的支持